Investigating an issue affecting loading times
Major incident
Lewes
2021-09-20 11:18 BST
· 24 minutes
Updates
Resolved
November 4, 2021 · 15:25 GMT
System is back up and we will continue to monitor the situation.
Monitoring
November 4, 2021 · 15:25 GMT
System is back up and we will continue to monitor the situation.
← Back