Lewes Fully Operational

Major incident Lewes
2021-03-03 10:47 BST · 5 hours, 49 minutes, 36 seconds

Updates

Resolved

Service is back up.

March 3, 2021 · 11:00 BST
Monitoring

We have monitored Lewes throughout the day and have seen no indications of further issue. The team will continue to monitor but this incident is now considered resolved.

March 3, 2021 · 10:47 BST

← Back