Service Lewes seems to be down

Major incident Lewes
2020-10-28 12:09 BST · 12 minutes, 33 seconds

Updates

Resolved

Service is back up.

October 28, 2020 · 12:22 BST
Issue

All services are fully operational with the team continuing to monitor application activity

October 28, 2020 · 12:09 BST

← Back