Brief Lewes Outage - Team actively monitoring but all systems now fully operational

Minor incident Lewes
2020-10-22 13:30 BST · 2 hours, 1 minute, 55 seconds

Updates

Resolved

All systems remain fully operational

October 22, 2020 · 15:32 BST
Monitoring

Small outage - Team actively investigating cause and monitoring application

October 22, 2020 · 13:31 BST

← Back