Investigating Issue on Lewes

Major incident Lewes
2020-06-19 09:26 BST · 54 minutes, 51 seconds

Updates

Resolved

This incident is now resolved. The team continue to monitor the situation and we thank you for your patience during this time

June 19, 2020 · 10:21 BST
Monitoring

System is back online. We will continue to monitor the situation

June 19, 2020 · 09:30 BST
Issue

We expect to be back online in 15 minutes

June 19, 2020 · 09:28 BST

← Back